MG-Rover.org Forums banner

1 - 12 of 12 Posts

·
Registered
'06 MG ZR +120 (HQM) '04 MG ZR 105 (IAB)
Joined
·
9,242 Posts
It is reasonably easy.
You will need to remove the clock surround which is simply clipped in - slide a flat blade screwdriver or similar under the bottom part of the surround (use a cloth to protect the top of the dash from damage) and prise the surround up and out. (it is wuite tight!)
You will then see the two cross head screws which hold the clock in place. They are set well back, so it is best to use a magnetic screwdriver if you have one. If not put something (the cloth perhaps) to stop them falling behind the dash if you drop them.
You can then lift the clock out and unclip the wiring plugs from the back.

Once the surround is ou, the rest is easy! :)
 

·
Registered
Joined
·
12,373 Posts
Yep...

Take a small flat bladed screwdriver and gently prise the surround away from the clock. Take car not to slip and mark the dash.

Once off there are two screws holding the clock in place. Undo these, be careful not to drop the screws into the dash! Use a magnetic scredriver if you have one.

Pull clock forward and then remove the connector.

Si:)
 

·
Registered
Joined
·
12,373 Posts
It is reasonably easy.
You will need to remove the clock surround which is simply clipped in - slide a flat blade screwdriver or similar under the bottom part of the surround (use a cloth to protect the top of the dash from damage) and prise the surround up and out. (it is wuite tight!)
You will then see the two cross head screws which hold the clock in place. They are set well back, so it is best to use a magnetic screwdriver if you have one. If not put something (the cloth perhaps) to stop them falling behind the dash if you drop them.
You can then lift the clock out and unclip the wiring plugs from the back.

Once the surround is ou, the rest is easy! :)
On the ball man! That was quick typing lol!

Si:)
 

·
Registered
'06 MG ZR +120 (HQM) '04 MG ZR 105 (IAB)
Joined
·
9,242 Posts
I thought as I was typing it "I bet someone else beats me to it", and was very surprised that no one had :lol:
I'm not quick on the keys at all, and usually need to spend time at the end correcting my typos!!
 

·
Registered
Joined
·
12,373 Posts
I thought as I was typing it "I bet someone else beats me to it", and was very surprised that no one had :lol:
I'm not quick on the keys at all, and usually need to spend time at the end correcting my typos!!
I was thinking the same...figured I would type all this out and...heh presto! A long comment above mine lol!

Rather have loads of folk doing the same posts than nobody answering.

Si:)
 

·
Registered
Joined
·
2 Posts
push the connector in and push down the tab then pull it
Thanks Yasmine I’ve managed to get the connector to give up its hold. I was expecting to find the ribbon damaged but all looks fine, gave it a clean up put it back together and all seems to be working fine.
Thanks again. Terry
 
1 - 12 of 12 Posts
Top