MG-Rover.org Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter #1
Hi,

Rover 75 2.5 V6 1998.

Previous engine was losing oil ~2l / 5000 km. No visible exhaust clouds, engine was running fine, pulling strong, sounded nice.
Changed the engine due to other considerations.
New engine from a reputable mechanic. Between MIX MAX there are the equivalent of 2l of oil right? Lost MIN MAX in 3000 km. Engine runs great, no smoke, pulls strong, sounds great. Coolant straight on the line without any loss, looking good, not oily. No leaks underneath the car.
I know it should lose some oil on the intake, but that is intended right?

My question is, might there be other external causes for that big of a loss? Again, 2 different engines with the same behaviour.

Thanks in advance,
Andi
 

·
Premium Member
Joined
·
2,087 Posts
My 1999 V6 2.5 has never lost any oil. I use to have a look every fortnight under the bonnet and no loss at all.
Regarding the difference between min & max, I think it cannot be 2 litres. You can easily see the min mark when oil is clear and the level at max. I may guess less than 0.5 litre. But I may be wrong because I've never experienced any top up between changes which I do every year & about 10k km (hardly more than 6 mls).
I'm sorry I can't help you very much and I'm sure that experts will come & tell you where & why.
 

·
Registered
MG ZT, Rover 25
Joined
·
5,675 Posts
If no leaks I’d guess at valve guide seals or rings. What’s the engine mileage?
 
1 - 4 of 4 Posts
Top