MG-Rover.org Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Ive read about this problem but no one has given a solution to it.
Ive got a MG ZR 2005 facelift, when you unlock & lock with key or fob they flash as normal, press the Hazard light button they go on & off no problem, put the key in & turn it, they start flashing & don't stop until you switch off the key again...
had a brand spanking new SCU.BCU Box fitted with 2 brand new fobs programmed & a new ECU, replaced every single relay & fuse in both fuse boxes, replaced all the switches on centre console, brand new back lights & loom........
Its doing my nut in. had to pull the fuse under bonnet just to drive it...
any more ideas???????? b4 i put a match to it
 

·
Rover Lifestyle
Rover 200 Rover 600
Joined
·
12,779 Posts
Ive read about this problem but no one has given a solution to it.
Ive got a MG ZR 2005 facelift, when you unlock & lock with key or fob they flash as normal, press the Hazard light button they go on & off no problem, put the key in & turn it, they start flashing & don't stop until you switch off the key again...
had a brand spanking new SCU.BCU Box fitted with 2 brand new fobs programmed & a new ECU, replaced every single relay & fuse in both fuse boxes, replaced all the switches on centre console, brand new back lights & loom........
Its doing my nut in. had to pull the fuse under bonnet just to drive it...
any more ideas???????? b4 i put a match to it
Most probably this is direct earth connection to hazard) switch connector pin-1 Light Green/Brown wire. This connection can be either on switch connector, or because of wire rubbing to metal radio cage and thus removing wire isolation and bare wire touching bare metal, thus erathing.
I do not know how good you are with multimeter, but at time when hazards start vlinking, you shoud remove hazard switch from connector, and on connector measure if you have continuation to earth. If you do, then that is the problem. You just need to find where this earthing is placed.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
I've Pulled live off battery terminal, then tested from live bat terminal to live cable & i defo got a short. but after pulling every fuse out one by one i couldn't locate the circuit that was grounding out, i will rip out all stereo etc to check wires.......The Horn docent work either ive noticed, don't now why be im starting to think the alarm is going off constantly. i pulled out the siren after not being able to disable it when my SCU relays started playing up. i could do with bypassing or takeing the entire alarm out.........******* pekron wants closed down so they can do something a lot less challenging , like selling toilet roll holders or something, because they cant do electronics to save them selfs........11 years with a MK1 no probs, Gets a MK2 & the hole the world falls apart, the wife says i spend more time playing with that car then her.... shes got a point.
 

·
Registered
'06 MG ZR +120 (HQM) '04 MG ZR 105 (IAB)
Joined
·
9,332 Posts
No good blaming Pektron for something that is fairly certainly not being caused by their equipment. Plenty of people have had Mk2 25s and ZRs without having any significant issues (and the zpektron system that you are getting yourself in a lather about was fitted to the Mk1 from the start of July 2003).

As for Pektron needing to do something less challenging, It appears that DIY maintenance is something that is beyond your capabilities. As YG said - take it to a garage.

You have a short somewhere - find it. You seem to have already replaced a lot of expensive components for nothing.
 
1 - 6 of 6 Posts
Top