MG-Rover.org Forums banner

1 - 2 of 2 Posts

·
Registered
rover_45
Joined
·
24 Posts
Discussion Starter · #1 ·
Just been to local Formula 1 as I suspected catalytic converter maybe need replacing but they could not read the code. They said there is a problem with the port. A few weeks ago I tried to reset the PO420 Inefficient Catalyst code with 2 different readers but both came up Link Error although they had read/cleared codes before with no problem. I have had a look at the plug but can't see anything broke but the metal plate surrounding it has light rust on it. Could the inside need cleaning? If so, what with? Can I replace it if not? Just looked on ebay after typing Rover 45 Diagnostic Port and it just comes up with readers.
Any advice welcome.
 

·
Registered
rover_45
Joined
·
24 Posts
Discussion Starter · #2 ·
Just been to local Formula 1 as I suspected catalytic converter maybe need replacing but they could not read the code. They said there is a problem with the port. A few weeks ago I tried to reset the PO420 Inefficient Catalyst code with 2 different readers but both came up Link Error although they had read/cleared codes before with no problem. I have had a look at the plug but can't see anything broke but the metal plate surrounding it has light rust on it. Could the inside need cleaning? If so, what with? Can I replace it if not? Just looked on ebay after typing Rover 45 Diagnostic Port and it just comes up with readers.
Any advice welcome.
Its working ok now. Found a can of Air Duster in my garage and sprayed it with that and my reader has found, again, PO420 and erased it.
 
1 - 2 of 2 Posts
Top